Использование функции =ВПР() в MS Excel

Столкнулся на днях со следующей задачей. Имеется два столбца с данными, при этом данные одного из столбцов частично содержаться в данных второго. Необходимо понять, какие данные содержаться только в первом столбце.

Средствами Excel эту задачу можно решить при помощи функции =ВПР().
Пусть на первом листе есть следующий список данных:


А на втором листе:

Поставим задачу вывести на первом листе рядом со значениями столбца «A» соответствующие значения столбца «B» со второго листа.
Для этого можно воспользоваться следующей формулой:

=ВПР(A1;Лист2!$A$1:$B$5;2;0)

Где:

«A1» — ячейка, по значению которой будет производится поиск соответствующих значений на втором листе;

Лист2!$A$1:$B$5 — ссылка на диапазон данных, в которых будет производиться поиск значения ячейки «A1» первого листа (Лист2! — ссылка на лист, $A$1:$B$5 — ссылка на диапазон, в котором будет вестись поиск (для того чтобы определить весь диапазон достаточно указать верхнюю левую и нижнюю правую ячейку диапазона), знаки $ означают абсолютную ссылку, то есть при применении формулы к другим ячейкам, ссылка на диапазон меняться не будет)

2 — порядковый номер столбца, из которого будут выбираться данные для вывода в ячейке, к которой применяется функция =ВПР(), в данном случае второму столбцу соответствует столбец «B»;

0 — запрет неточного поиска, то есть если во втором листе в столбце «A» не будет значений совпадающих со значением ячейки того же столбца первого листа, то функция вернет ошибку. Если указать «1», то вернет наиболее близкое значение.

После применения к столбцу «B» описанной функции получим следующий результат:

Значения «#Н/Д» означают, что на втором листе не было найдено значений соответствующих значению ячеек A1, A3, A5.

Чтобы избавится от таких значений (#Н/Д) можно воспользоваться формулой:

=ЕСЛИ(ЕНД(ВПР(A1;Лист2!$A$1:$B$5;2;0));"";ВПР(A1;Лист2!$A$1:$B$5;2;0))

Где функция =ЕНД() возвращает «ИСТИНА», в том случае, если в столбце ошибка «#Н/Д».
Окончательный результат в столбце «C» будет выглядеть следующим образом:

Вместо ссылки на второй столбец второго листа можно указать ссылку на первый столбец, тогда получим:


Установив фильтр и выбрав все пустые ячейки в столбце «C», в столбце «A» получим решение начальной задачи — список всех значений содержащихся только в первом рассматриваемом столбце.

Более подробно о функции =ВПР() вы можете прочесть на сайте «Профессиональные приемы работы в Microsoft Excel».

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *